Honda TRX 450R banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Okay so I have a very odd misfire at high rpm, the bike has 12.5:1 piston, stage 2 hot cam, empire full exhaust, uni filter with lid off and big gun rev box (yes I know they are junk).

I have tried jetting as far either direction as possible with no change, I put a new stator in it no change, checked for exhaust leaks and air leaks, valves were shimmed less then 10 hours ago, changed spark plug and checked boot for damage, swapped the REV box with a known good OEM ICM.

The problem was very noticeable when I started diagnosing it and now it is a very small misfire when cruising in high RPM or when you are pegged right before the limiter and almost feels like it is tickling the rev limiter but it also happens in slightly lower RPM then that sometimes.

When I put in the new spark plug that is when it started to get much better then before but I’m confused as to why it didn’t completely fix it and I’m not sure where to go from here. Currently running a 185 main jet, 48 pilot, needle on 3rd clip and 2.75 turns on the fuel screw. Any help would be very much appreciated.
 

·
Registered
2014 trx450er
Joined
·
9 Posts
Okay so I have a very odd misfire at high rpm, the bike has 12.5:1 piston, stage 2 hot cam, empire full exhaust, uni filter with lid off and big gun rev box (yes I know they are junk).

I have tried jetting as far either direction as possible with no change, I put a new stator in it no change, checked for exhaust leaks and air leaks, valves were shimmed less then 10 hours ago, changed spark plug and checked boot for damage, swapped the REV box with a known good OEM ICM.

The problem was very noticeable when I started diagnosing it and now it is a very small misfire when cruising in high RPM or when you are pegged right before the limiter and almost feels like it is tickling the rev limiter but it also happens in slightly lower RPM then that sometimes.

When I put in the new spark plug that is when it started to get much better then before but I’m confused as to why it didn’t completely fix it and I’m not sure where to go from here. Currently running a 185 main jet, 48 pilot, needle on 3rd clip and 2.75 turns on the fuel screw. Any help would be very much appreciated.
I didn't see anything on what fuel you are running, sounds like you might be running to low of an octane with the higher compression piston, hope this helps.
 
1 - 2 of 2 Posts
Top